PHP 5 Datum/UhrzeitFunktionen


PHP Datum/Uhrzeit-Einführung

Die Date/Time-Funktionen ermöglichen es Ihnen, das Datum und die Uhrzeit vom Server abzurufen, auf dem Ihr PHP-Skript ausgeführt wird. Sie können die Date/Time-Funktionen verwenden, um Datums- und Uhrzeitangaben auf verschiedene Weise zu formatieren.

Hinweis:Diese Funktionen hängen von den lokalen Einstellungen des Servers ab. Wenn Sie diese Funktionen verwenden, denken Sie daran, die Sommerzeit und Schaltjahre zu berücksichtigen.


Installation

Die PHP Date/Time-Funktionen sind Teil des PHP-Kerns. Für die Verwendung dieser Funktionen ist keine Installation erforderlich.


Laufzeitkonfiguration

Das Verhalten der Date/Time-Funktionen wird durch Einstellungen in der php.ini beeinflusst:

Name Beschreibung Standard PHP-Version
date.timezone Gibt die Standardzeitzone an (wird von allen Date/Time-Funktionen verwendet) "" PHP 5.1
date.default_latitude Gibt den Standard-Breitengrad an (wird von date_sunrise() und date_sunset() verwendet) "31.7667" PHP 5.0
date.default_longitude Gibt den Standard-Längengrad an (wird von date_sunrise() und date_sunset() verwendet) "35.2333" PHP 5.0
date.sunrise_zenith Gibt den standardmäßigen Sonnenaufgangs-Zenit an (verwendet von date_sunrise() und date_sunset()) "90.83" PHP 5.0
date.sunset_zenith Gibt den standardmäßigen Sonnenuntergangs-Zenit an (verwendet von date_sunrise() und date_sunset()) "90.83" PHP 5.0


PHP 5 Datum/Uhrzeit-Funktionen

Funktion Beschreibung
checkdate() Validiert ein gregorianisches Datum.
date_add() Fügt einem Datum Tage, Monate, Jahre, Stunden, Minuten und Sekunden hinzu.
date_create_from_format() Gibt ein neues DateTime-Objekt zurück, das gemäß dem angegebenen Format formatiert ist.
date_create() Gibt ein neues DateTime-Objekt zurück.
date_date_set() Legt ein neues Datum fest.
date_default_timezone_get() Gibt die Standardzeitzone zurück, die von allen Datums-/Zeitfunktionen verwendet wird.
date_default_timezone_set() Legt die Standardzeitzone fest, die von allen Datums-/Zeitfunktionen verwendet wird.
date_diff() Gibt die Differenz zwischen zwei Datumsangaben zurück.
date_format() Gibt ein Datum zurück, das gemäß dem angegebenen Format formatiert ist.
date_get_last_errors() Gibt Warnungen/Fehler in einer Datumszeichenfolge zurück.
date_interval_create_from_date_string() Erstellt ein DateInterval aus den relativen Teilen eines Strings.
date_interval_format() Formatiert ein Zeitintervall.
date_isodate_set() Legt ein ISO-Datum fest.
date_modify() Ändert einen Zeitstempel.
date_offset_get() Gibt den Zeitzonen-Offset zurück.
date_parse_from_format() Gibt ein assoziatives Array mit detaillierten Informationen über ein angegebenes Datum gemäß dem angegebenen Format zurück.
date_parse() Gibt ein assoziatives Array mit detaillierten Informationen zu einem angegebenen Datum zurück.
date_sub() Subtrahiert Tage, Monate, Jahre, Stunden, Minuten und Sekunden von einem angegebenen Datum.
date_sun_info() Gibt ein Array mit Informationen zu Sonnenaufgang/-untergang und Beginn/Ende der Dämmerung für ein angegebenes Datum und einen angegebenen Ort zurück.
date_sunrise() Gibt die Sonnenaufgangszeit für ein angegebenes Datum und einen angegebenen Ort zurück.
date_sunset() Gibt die Sonnenuntergangszeit für ein angegebenes Datum und einen angegebenen Ort zurück.
date_time_set() Setzt die Uhrzeit.
date_timestamp_get() Gibt den Unix-Zeitstempel zurück.
date_timestamp_set() Legt Datum und Uhrzeit basierend auf einem Unix-Zeitstempel fest.
date_timezone_get() Gibt die Zeitzone des angegebenen DateTime-Objekts zurück.
date_timezone_set() Legt die Zeitzone eines DateTime-Objekts fest.
date() Formatiert ein lokales Datum und eine lokale Uhrzeit.
getdate() Gibt Datums-/Uhrzeitinformationen für einen Zeitstempel oder das aktuelle lokale Datum/die aktuelle lokale Uhrzeit zurück.
gettimeofday() Gibt die aktuelle Zeit zurück.
gmdate() Formatiert ein GMT/UTC-Datum und eine Uhrzeit.
gmmktime() Gibt einen Unix-Zeitstempel für ein GMT-Datum zurück.
gmstrftime() Formatiert ein GMT/UTC-Datum und eine Uhrzeit gemäß den Locale-Einstellungen.
idate() Formatiert eine lokale Uhrzeit/ein lokales Datum als Ganzzahl.
localtime() Gibt die lokale Zeit zurück.
microtime() Gibt die Mikrosekunden des aktuellen Unix-Zeitstempels zurück.
mktime() Gibt den Unix-Zeitstempel für ein Datum zurück.
strftime() Formatiert ein lokales Datum/eine lokale Uhrzeit gemäß den Locale-Einstellungen.
strptime() Parst ein von strftime() erzeugtes Datum/eine Uhrzeit.
strtotime() Parst jede englische textliche Datums- oder Zeitbeschreibung in einen Unix-Zeitstempel.
time() Gibt die aktuelle Zeit als Unix-Zeitstempel zurück.
timezone_abbreviations_list() Gibt ein assoziatives Array zurück, das Sommerzeit, Offset und Zeitzonennamen enthält.
timezone_identifiers_list() Gibt ein numerisches Array zurück, das alle Zeitzonen-Identifikatoren enthält.
timezone_location_get() Gibt Standortinformationen für eine angegebene Zeitzone zurück.
timezone_name_from_ abbr() Gibt den Zeitzonennamen aus einer Zeitzonenabkürzung zurück.
timezone_name_get() Gibt den Namen der Zeitzone zurück.
timezone_offset_get() Gibt den Zeitzonen-Offset relativ zu GMT zurück.
timezone_open() Erstellt ein neues DateTimeZone-Objekt.
timezone_transitions_get() Gibt alle Übergänge für eine Zeitzone zurück.
timezone_version_get() Gibt die Version der Zeitzonendatenbank zurück.


PHP 5 vordefinierte Datums-/Zeitkonstanten

Konstante Beschreibung
DATE_ATOM Atom (z. B. 2005-08-15T16:13:03+0000)
DATE_COOKIE HTTP-Cookies (z. B. Sun, 14 Aug 2005 16:13:03 UTC)
DATE_ISO8601 ISO-8601 (z. B. 2005-08-14T16:13:03+0000)
DATE_RFC822 RFC 822 (z. B. Sun, 14 Aug 2005 16:13:03 UTC)
DATE_RFC850 RFC 850 (z. B. Sunday, 14-Aug-05 16:13:03 UTC)
DATE_RFC1036 RFC 1036 (z. B. Sunday, 14-Aug-05 16:13:03 UTC)
DATE_RFC1123 RFC 1123 (z. B. Sun, 14 Aug 2005 16:13:03 UTC)
DATE_RFC2822 RFC 2822 (z. B. Sun, 14 Aug 2005 16:13:03 +0000)
DATE_RSS RSS (z. B. Sun, 14 Aug 2005 16:13:03 UTC)
DATE_W3C W3C (e.g., 2005-08-14T16:13:03+0000)
Andere Erweiterungen