PHP gmdate()Funktionen

PHP Date/TimePHP Date/Time-Referenzhandbuch

Beispiele

Formatiert ein GMT/UTC-Datum und eine Uhrzeit und gibt die formatierte Datumszeichenkette zurück:

<?php
// Gibt den Tag aus
echo gmdate("l") . "<br>";

// Gibt den Tag, Datum, Monat, Jahr, Uhrzeit, AM oder PM aus
echo gmdate("l jS of F Y h:i:s A");
?>

Beispiel ausführen »

Definition und Verwendung

Die Funktion gmdate() formatiert ein GMT/UTC-Datum und eine Uhrzeit und gibt die formatierte Datumszeichenkette zurück.

Syntax

gmdate(format,timestamp);

Parameter Beschreibung
format Erforderlich. Legt das Format der Ausgabe-Datumszeichenfolge fest. Die folgenden Zeichen können verwendet werden:
  • d - Tag des Monats (von 01 bis 31)
  • D - Eine textliche Darstellung des Wochentags (drei Buchstaben)
  • j - Tag des Monats ohne führende Nullen (1 bis 31)
  • l (kleines 'L') - Eine vollständige textliche Darstellung des Wochentags
  • N - Die numerische Darstellung des Wochentags nach ISO-8601 (1 für Montag, 7 für Sonntag)
  • S - Das englische Ordinalsuffix für den Tag des Monats (2 Zeichen: st, nd, rd oder th. Funktioniert gut mit j)
  • w - Numerische Darstellung des Wochentags (0 für Sonntag, 6 für Samstag)
  • z - Der Tag des Jahres (von 0 bis 365)
  • W - Die ISO-8601-Wochennummer des Jahres (Wochen beginnen am Montag)
  • F - Eine vollständige textliche Darstellung des Monats (Januar bis Dezember)
  • m - Numerische Darstellung des Monats (von 01 bis 12)
  • M - Eine kurze textliche Darstellung des Monats (drei Buchstaben)
  • n - Numerische Darstellung des Monats ohne führende Nullen (1 bis 12)
  • t - Die Anzahl der Tage im angegebenen Monat
  • L - Ob es ein Schaltjahr ist (1, wenn es ein Schaltjahr ist, sonst 0)
  • o - Die ISO-8601-Jahresnummer
  • Y - Eine vierstellige Darstellung des Jahres
  • y - Eine zweistellige Darstellung des Jahres
  • a - Kleingeschriebene Form: am oder pm
  • A - Großgeschriebene Form: AM oder PM
  • B - Swatch Internet Time (000 bis 999)
  • g - 12-Stunden-Format ohne führende Nullen (1 bis 12)
  • G - 24-Stunden-Format ohne führende Nullen (0 bis 23)
  • h - 12-Stunden-Format mit führenden Nullen (01 bis 12)
  • H - 24-Stunden-Format mit führenden Nullen (00 bis 23)
  • i - Minuten mit führenden Nullen (00 bis 59)
  • s - Sekunden mit führenden Nullen (00 bis 59)
  • u - Mikrosekunden (hinzugefügt in PHP 5.2.2)
  • e - Zeitzonenbezeichner (z. B.: UTC, GMT, Atlantic/Azores)
  • I (großes i) - Gibt an, ob das Datum in der Sommerzeit liegt (1, wenn Sommerzeit, sonst 0)
  • O - Differenz zur Greenwich-Zeit (GMT) in Stunden (Beispiel: +0100)
  • P - Differenz zur Greenwich-Zeit (GMT) in Stunden:Minuten (hinzugefügt in PHP 5.1.3)
  • T - Zeitzonenabkürzung (Beispiele: EST, MDT)
  • Z - Zeitzonenversatz in Sekunden. Der Versatz für Zeitzonen westlich von UTC ist negativ (-43200 bis 50400)
  • c - Das ISO-8601-Datum (z. B. 2013-05-05T16:34:42+00:00)
  • r - Das nach RFC 2822 formatierte Datum (z. B. Fri, 12 Apr 2013 12:01:05 +0200)
  • U - Die Anzahl der Sekunden seit der Unix-Epoche (1. Januar 1970 00:00:00 GMT)

Zusätzlich können die folgenden vordefinierten Konstanten verwendet werden (verfügbar seit PHP 5.1.0):

  • DATE_ATOM - Atom (z. B.: 2013-04-12T15:52:01+00:00)
  • DATE_COOKIE - HTTP-Cookies (z. B.: Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_ISO8601 - ISO-8601 (z. B.: 2013-04-12T15:52:01+0000)
  • DATE_RFC822 - RFC 822 (z. B.: Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC850 - RFC 850 (z. B.: Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_RFC1036 - RFC 1036 (z. B.: Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC1123 - RFC 1123 (z. B.: Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC2822 - RFC 2822(Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC3339 - Identisch mit DATE_ATOM (seit PHP 5.1.3)
  • DATE_RSS - RSS(Fri, 12 Aug 2013 15:52:01 +0000)
  • DATE_W3C - World Wide Web Consortium (z. B.: 2013-04-12T15:52:01+00:00)
timestamp Optional. Gibt einen ganzzahligen Unix-Zeitstempel an. Standard ist die aktuelle lokale Zeit (time()).

Technische Details

Rückgabewert: Gibt bei Erfolg die formatierte Datumszeichenfolge zurück; bei Fehler wird eine E_WARNING ausgegeben und FALSE zurückgegeben.
PHP-Version: 4+
Änderungsprotokoll: PHP 5.1.0: Der gültige Bereich von Zeitstempeln reicht von Freitag, 13. Dezember 1901 20:45:54 GMT bis Dienstag, 19. Januar 2038 03:14:07 GMT. Vor Version 5.1.0 waren Zeitstempel auf einigen Systemen (z. B. Windows) auf 01-01-1970 bis 19-01-2038 beschränkt.
PHP 5.1.1: Standardkonstanten für Datums-/Zeitformate zur Angabe des Formatparameters hinzugefügt.


PHP Date/TimePHP Date/Time-Referenzhandbuch Andere Erweiterungen