PHP 5 Date/Time関数


PHP Date/Time の概要

Date/Time 関数を使用すると、PHP スクリプトが実行されているサーバーから日付と時刻を取得できます。Date/Time 関数を使用して、日付と時刻をさまざまな方法でフォーマットできます。

注:これらの関数はサーバーのローカル設定に依存します。これらの関数を使用する際は、夏時間とうるう年を考慮する必要があることに注意してください。


インストール

PHP Date/Time 関数は PHP コアの一部です。インストールなしでこれらの関数を使用できます。


ランタイム設定

Date/Time 関数の動作は、php.ini の設定によって影響を受けます:

名前 説明 デフォルト PHP バージョン
date.timezone デフォルトのタイムゾーンを指定します(すべての Date/Time 関数がこのオプションを使用します) "" PHP 5.1
date.default_latitude デフォルトの緯度を指定します(date_sunrise() と date_sunset() がこのオプションを使用します) "31.7667" PHP 5.0
date.default_longitude デフォルトの経度を指定します(date_sunrise() と date_sunset() がこのオプションを使用します) "35.2333" PHP 5.0
date.sunrise_zenith デフォルトの日の出の天頂を指定します(date_sunrise() と date_sunset() がこのオプションを使用します) "90.83" PHP 5.0
date.sunset_zenith デフォルトの日の入りの天頂を指定します(date_sunrise() と date_sunset() がこのオプションを使用します) "90.83" PHP 5.0


PHP 5 Date/Time 関数

関数 説明
checkdate() グレゴリオ暦の日付を検証します。
date_add() 日、月、年、時、分、秒を日付に追加します。
date_create_from_format() 指定された形式に従ってフォーマットされた新しい DateTime オブジェクトを返します。
date_create() 新しい DateTime オブジェクトを返します。
date_date_set() 新しい日付を設定します。
date_default_timezone_get() すべての Date/Time 関数で使用されるデフォルトのタイムゾーンを返します。
date_default_timezone_set() すべての Date/Time 関数で使用されるデフォルトのタイムゾーンを設定します。
date_diff() 2つの日付の間の差を返します。
date_format() 指定された形式に従ってフォーマットされた日付を返します。
date_get_last_errors() 日付文字列に含まれる警告/エラーを返します。
date_interval_create_from_date_string() 文字列の相対的な部分から DateInterval を作成します。
date_interval_format() 時間間隔をフォーマットします。
date_isodate_set() ISO 日付を設定します。
date_modify() タイムスタンプを変更します。
date_offset_get() タイムゾーンのオフセットを返します。
date_parse_from_format() 指定された形式に従って、指定された日付の詳細情報を含む連想配列を返します。
date_parse() 指定された日付の詳細情報を含む連想配列を返します。
date_sub() 指定された日付から日、月、年、時、分、秒を減算します。
date_sun_info() 指定された日付と場所に関する日の出/日の入り、および薄明の開始/終了の情報を含む配列を返します。
date_sunrise() 指定された日付と場所の日の出の時刻を返します。
date_sunset() 指定された日付と場所の日の入りの時刻を返します。
date_time_set() 時刻を設定します。
date_timestamp_get() Unix タイムスタンプを返します。
date_timestamp_set() Unix タイムスタンプに基づいて日付と時刻を設定します。
date_timezone_get() 指定された DateTime オブジェクトのタイムゾーンを返します。
date_timezone_set() DateTime オブジェクトのタイムゾーンを設定します。
date() ローカル日付と時刻をフォーマットします。
getdate() タイムスタンプまたは現在のローカル日付/時刻の日付/時刻情報を返します。
gettimeofday() 現在の時刻を返します。
gmdate() GMT/UTC の日付と時刻をフォーマットします。
gmmktime() GMT 日付の UNIX タイムスタンプを返します。
gmstrftime() ロケール設定に基づいて GMT/UTC の日付と時刻をフォーマットします。
idate() ローカル時刻/日付を整数としてフォーマットします。
localtime() ローカル時刻を返します。
microtime() 現在の Unix タイムスタンプのマイクロ秒数を返します。
mktime() 日付の Unix タイムスタンプを返します。
strftime() ロケール設定に基づいてローカル時刻/日付をフォーマットします。
strptime() strftime() によって生成された時刻/日付を解析します。
strtotime() 任意の英語テキストによる日付または時刻の記述を Unix タイムスタンプに解析します。
time() 現在の時刻の Unix タイムスタンプを返します。
timezone_abbreviations_list() 夏時間、オフセット、およびタイムゾーン名を含む連想配列を返します。
timezone_identifiers_list() すべてのタイムゾーン識別子を含む数値配列を返します。
timezone_location_get() 指定されたタイムゾーンの位置情報を返します。
timezone_name_from_ abbr() タイムゾーンの略語に基づいてタイムゾーン名を返します。
timezone_name_get() タイムゾーンの名前を返します。
timezone_offset_get() GMT に対するタイムゾーンオフセットを返します。
timezone_open() 新しい DateTimeZone オブジェクトを作成します。
timezone_transitions_get() タイムゾーンのすべての遷移を返します。
timezone_version_get() タイムゾーンデータベースのバージョンを返します。


PHP 5 の定義済み Date/Time 定数

定数 説明
DATE_ATOM Atom (例:2005-08-15T16:13:03+0000)
DATE_COOKIE HTTP Cookies (例:Sun, 14 Aug 2005 16:13:03 UTC)
DATE_ISO8601 ISO-8601 (例:2005-08-14T16:13:03+0000)
DATE_RFC822 RFC 822 (例:Sun, 14 Aug 2005 16:13:03 UTC)
DATE_RFC850 RFC 850 (例:Sunday, 14-Aug-05 16:13:03 UTC)
DATE_RFC1036 RFC 1036 (例:Sunday, 14-Aug-05 16:13:03 UTC)
DATE_RFC1123 RFC 1123 (例:Sun, 14 Aug 2005 16:13:03 UTC)
DATE_RFC2822 RFC 2822 (例:Sun, 14 Aug 2005 16:13:03 +0000)
DATE_RSS RSS (例:Sun, 14 Aug 2005 16:13:03 UTC)
DATE_W3C W3C (例:2005-08-14T16:13:03+0000)
その他の拡張