PHP 5 Date/TimeFunciones
Introducción a PHP Date/Time
Las funciones Date/Time le permiten obtener la fecha y la hora del servidor en el que se ejecuta el script de PHP. Puede usar las funciones Date/Time para formatear la fecha y la hora de diferentes maneras.
Nota:Estas funciones dependen de la configuración local del servidor. Al usar estas funciones, recuerde tener en cuenta el horario de verano y los años bisiestos.
Instalación
Las funciones Date/Time de PHP son parte del núcleo de PHP. No es necesario instalarlas para usarlas.
Configuración de Runtime
El comportamiento de las funciones Date/Time se ve afectado por la configuración en php.ini:
| Nombre | Descripción | Predeterminado | Versión de PHP |
|---|---|---|---|
| date.timezone | Especifica la zona horaria predeterminada (todas las funciones Date/Time usan esta opción) | "" | PHP 5.1 |
| date.default_latitude | Especifica la latitud predeterminada (usada por date_sunrise() y date_sunset()) | "31.7667" | PHP 5.0 |
| date.default_longitude | Especifica la longitud predeterminada (usada por date_sunrise() y date_sunset()) | "35.2333" | PHP 5.0 |
| date.sunrise_zenith | Especifica el cénit de salida del sol predeterminado (usado por date_sunrise() y date_sunset()) | "90.83" | PHP 5.0 |
| date.sunset_zenith | Especifica el cénit de puesta del sol predeterminado (usado por date_sunrise() y date_sunset()) | "90.83" | PHP 5.0 |
Funciones Date/Time de PHP 5
| Función | Descripción |
|---|---|
| checkdate() | Valida una fecha gregoriana. |
| date_add() | Agrega días, meses, años, horas, minutos y segundos a una fecha. |
| date_create_from_format() | Devuelve un nuevo objeto DateTime formateado según el formato especificado. |
| date_create() | Devuelve un nuevo objeto DateTime. |
| date_date_set() | Establece una nueva fecha. |
| date_default_timezone_get() | Devuelve la zona horaria predeterminada usada por todas las funciones Date/Time. |
| date_default_timezone_set() | Establece la zona horaria predeterminada usada por todas las funciones Date/Time. |
| date_diff() | Devuelve la diferencia entre dos fechas. |
| date_format() | Devuelve una fecha formateada según el formato especificado. |
| date_get_last_errors() | Devuelve las advertencias/errores de una cadena de fecha. |
| date_interval_create_from_date_string() | Crea un DateInterval a partir de las partes relevantes de una cadena. |
| date_interval_format() | Da formato a un intervalo de tiempo. |
| date_isodate_set() | Establece la fecha ISO. |
| date_modify() | Modifica la marca de tiempo. |
| date_offset_get() | Devuelve la desviación de la zona horaria. |
| date_parse_from_format() | Devuelve una matriz asociativa con los detalles de una fecha especificada según el formato especificado. |
| date_parse() | Devuelve una matriz asociativa con los detalles de una fecha especificada. |
| date_sub() | Resta días, meses, años, horas, minutos y segundos a una fecha especificada. |
| date_sun_info() | Devuelve una matriz con información sobre la salida/puesta del sol y el inicio/fin del crepúsculo para una fecha y ubicación especificadas. |
| date_sunrise() | Devuelve la hora de salida del sol para una fecha y ubicación especificadas. |
| date_sunset() | Devuelve la hora de puesta del sol para una fecha y ubicación especificadas. |
| date_time_set() | Establece la hora. |
| date_timestamp_get() | Devuelve una marca de tiempo Unix. |
| date_timestamp_set() | Establece la fecha y la hora basadas en una marca de tiempo Unix. |
| date_timezone_get() | Devuelve la zona horaria de un objeto DateTime dado. |
| date_timezone_set() | Establece la zona horaria de un objeto DateTime. |
| date() | Da formato a la fecha y hora locales. |
| getdate() | Devuelve información de fecha/hora de una marca de tiempo o de la fecha/hora local actual. |
| gettimeofday() | Devuelve la hora actual. |
| gmdate() | Da formato a la fecha y hora GMT/UTC. |
| gmmktime() | Devuelve una marca de tiempo Unix para una fecha GMT. |
| gmstrftime() | Da formato a la fecha y hora GMT/UTC según la configuración regional. |
| idate() | Formatea la hora/fecha local como un entero. |
| localtime() | Devuelve la hora local. |
| microtime() | Devuelve los microsegundos de la marca de tiempo Unix actual. |
| mktime() | Devuelve la marca de tiempo Unix de una fecha. |
| strftime() | Da formato a la hora/fecha local según la configuración regional. |
| strptime() | Analiza la hora/fecha generada por strftime(). |
| strtotime() | Analiza cualquier descripción de fecha u hora en texto inglés como una marca de tiempo Unix. |
| time() | Devuelve la marca de tiempo Unix de la hora actual. |
| timezone_abbreviations_list() | Devuelve una matriz asociativa que contiene el horario de verano, la desviación y el nombre de la zona horaria. |
| timezone_identifiers_list() | Devuelve una matriz numérica con todos los identificadores de zona horaria. |
| timezone_location_get() | Devuelve la información de ubicación de una zona horaria especificada. |
| timezone_name_from_ abbr() | Devuelve el nombre de la zona horaria según la abreviatura de zona horaria. |
| timezone_name_get() | Devuelve el nombre de la zona horaria. |
| timezone_offset_get() | Devuelve la desviación de la zona horaria en relación con GMT. |
| timezone_open() | Crea un nuevo objeto DateTimeZone. |
| timezone_transitions_get() | Devuelve todas las transiciones de la zona horaria. |
| timezone_version_get() | Devuelve la versión de la base de datos de zonas horarias. |
Constantes Date/Time predefinidas de PHP 5
| Constante | Descripción |
|---|---|
| DATE_ATOM | Atom (por ejemplo: 2005-08-15T16:13:03+0000) |
| DATE_COOKIE | HTTP Cookies (por ejemplo: Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_ISO8601 | ISO-8601 (por ejemplo: 2005-08-14T16:13:03+0000) |
| DATE_RFC822 | RFC 822 (por ejemplo: Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_RFC850 | RFC 850 (por ejemplo: Sunday, 14-Aug-05 16:13:03 UTC) |
| DATE_RFC1036 | RFC 1036 (por ejemplo: Sunday, 14-Aug-05 16:13:03 UTC) |
| DATE_RFC1123 | RFC 1123 (por ejemplo: Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_RFC2822 | RFC 2822 (por ejemplo: Sun, 14 Aug 2005 16:13:03 +0000) |
| DATE_RSS | RSS (por ejemplo: Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_W3C | World Wide Web Consortium (por ejemplo: 2005-08-14T16:13:03+0000) |