PHP 5 Date/HeureFonctions


Introduction à Date/Heure de PHP

Les fonctions Date/Heure vous permettent d'obtenir la date et l'heure du serveur sur lequel votre script PHP s'exécute. Vous pouvez utiliser les fonctions Date/Heure pour formater les dates et les heures de différentes manières.

Remarque :Ces fonctions dépendent des paramètres locaux du serveur. Lorsque vous utilisez ces fonctions, n'oubliez pas de tenir compte de l'heure d'été et des années bissextiles.


Installation

Les fonctions Date/Heure de PHP font partie du cœur de PHP. Aucune installation n'est requise pour utiliser ces fonctions.


Configuration à l'exécution

Le comportement des fonctions Date/Heure est affecté par les paramètres de php.ini :

Name Description Default Version de PHP
date.timezone Spécifie le fuseau horaire par défaut (utilisé par toutes les fonctions Date/Heure) "" PHP 5.1
date.default_latitude Spécifie la latitude par défaut (utilisée par date_sunrise() et date_sunset()) "31.7667" PHP 5.0
date.default_longitude Spécifie la longitude par défaut (utilisée par date_sunrise() et date_sunset()) "35.2333" PHP 5.0
date.sunrise_zenith Spécifie le zénith de lever du soleil par défaut (utilisé par date_sunrise() et date_sunset()) "90.83" PHP 5.0
date.sunset_zenith Spécifie le zénith de coucher du soleil par défaut (utilisé par date_sunrise() et date_sunset()) "90.83" PHP 5.0


Fonctions de date/heure PHP 5

Fonction Description
checkdate() Valide une date grégorienne.
date_add() Ajoute des jours, des mois, des années, des heures, des minutes et des secondes à une date.
date_create_from_format() Retourne un nouvel objet DateTime formaté selon le format spécifié.
date_create() Retourne un nouvel objet DateTime.
date_date_set() Définit une nouvelle date.
date_default_timezone_get() Retourne le fuseau horaire par défaut utilisé par toutes les fonctions Date/Heure.
date_default_timezone_set() Définit le fuseau horaire par défaut utilisé par toutes les fonctions Date/Heure.
date_diff() Retourne la différence entre deux dates.
date_format() Retourne une date formatée selon le format spécifié.
date_get_last_errors() Retourne les avertissements/erreurs dans une chaîne de date.
date_interval_create_from_date_string() Crée un DateInterval à partir des parties relatives d'une chaîne.
date_interval_format() Formate un intervalle de temps.
date_isodate_set() Définit une date ISO.
date_modify() Modifie un horodatage.
date_offset_get() Retourne le décalage horaire.
date_parse_from_format() Retourne un tableau associatif avec des informations détaillées sur une date spécifiée, selon le format spécifié.
date_parse() Retourne un tableau associatif contenant des informations détaillées sur une date spécifiée.
date_sub() Soustrait des jours, des mois, des années, des heures, des minutes et des secondes à une date spécifiée.
date_sun_info() Retourne un tableau contenant des informations sur le lever/coucher du soleil et le début/fin du crépuscule pour une date et un lieu spécifiés.
date_sunrise() Retourne l'heure du lever du soleil pour une date et un lieu spécifiés.
date_sunset() Retourne l'heure du coucher du soleil pour une date et un lieu spécifiés.
date_time_set() Définit l'heure.
date_timestamp_get() Retourne le timestamp Unix.
date_timestamp_set() Définit la date et l'heure à partir d'un timestamp Unix.
date_timezone_get() Retourne le fuseau horaire de l'objet DateTime donné.
date_timezone_set() Définit le fuseau horaire d'un objet DateTime.
date() Formate une date et une heure locales.
getdate() Retourne les informations de date/heure pour un timestamp ou la date/heure locale actuelle.
gettimeofday() Retourne l'heure actuelle.
gmdate() Formate une date et une heure GMT/UTC.
gmmktime() Retourne un horodatage Unix pour une date GMT.
gmstrftime() Formate une date et une heure GMT/UTC selon les paramètres régionaux.
idate() Formate une heure/date locale sous forme d'entier.
localtime() Retourne l'heure locale.
microtime() Renvoie les microsecondes de l'horodatage Unix actuel.
mktime() Renvoie l'horodatage Unix pour une date.
strftime() Formate une heure/date locale selon les paramètres régionaux.
strptime() Analyse une heure/date générée par strftime().
strtotime() Analyse toute description textuelle anglaise de date ou d'heure en un horodatage Unix.
time() Renvoie l'heure actuelle sous la forme d'un horodatage Unix.
timezone_abbreviations_list() Renvoie un tableau associatif contenant l'heure d'été, le décalage et le nom du fuseau horaire.
timezone_identifiers_list() Renvoie un tableau numérique contenant tous les identifiants de fuseaux horaires.
timezone_location_get() Renvoie les informations de localisation pour un fuseau horaire spécifié.
timezone_name_from_ abbr() Renvoie le nom du fuseau horaire à partir d'une abréviation de fuseau horaire.
timezone_name_get() Renvoie le nom du fuseau horaire.
timezone_offset_get() Renvoie le décalage du fuseau horaire par rapport à GMT.
timezone_open() Crée un nouvel objet DateTimeZone.
timezone_transitions_get() Renvoie toutes les transitions pour un fuseau horaire.
timezone_version_get() Renvoie la version de la base de données des fuseaux horaires.


Constantes Date/Heure prédéfinies de PHP 5

Constante Description
DATE_ATOM Atom (par exemple, 2005-08-15T16:13:03+0000)
DATE_COOKIE Cookies HTTP (par exemple, Sun, 14 Aug 2005 16:13:03 UTC)
DATE_ISO8601 ISO-8601 (par exemple, 2005-08-14T16:13:03+0000)
DATE_RFC822 RFC 822 (par ex., Sun, 14 Aug 2005 16:13:03 UTC)
DATE_RFC850 RFC 850 (par ex., Sunday, 14-Aug-05 16:13:03 UTC)
DATE_RFC1036 RFC 1036 (par ex., Sunday, 14-Aug-05 16:13:03 UTC)
DATE_RFC1123 RFC 1123 (par ex., Sun, 14 Aug 2005 16:13:03 UTC)
DATE_RFC2822 RFC 2822 (par ex., Sun, 14 Aug 2005 16:13:03 +0000)
DATE_RSS RSS (par ex., Sun, 14 Aug 2005 16:13:03 UTC)
DATE_W3C W3C (e.g., 2005-08-14T16:13:03+0000)
Autres extensions