PHP 5 : функции даты/времениFunctions
Введение в работу с датой/временем в PHP
Функции даты/времени позволяют получать дату и время с сервера, на котором выполняется ваш PHP-скрипт. С помощью функций даты/времени можно форматировать дату и время различными способами.
Примечание:Эти функции зависят от локальных настроек сервера. При использовании этих функций не забывайте учитывать переход на летнее время и високосные годы.
Установка
Функции даты/времени PHP являются частью ядра PHP. Для использования этих функций установка не требуется.
Настройка во время выполнения
На поведение функций даты/времени влияют настройки в php.ini:
| Name | Описание | Default | Версия PHP |
|---|---|---|---|
| date.timezone | Задает часовой пояс по умолчанию (используется всеми функциями даты/времени) | "" | PHP 5.1 |
| date.default_latitude | Задает широту по умолчанию (используется date_sunrise() и date_sunset()) | "31.7667" | PHP 5.0 |
| date.default_longitude | Задает долготу по умолчанию (используется date_sunrise() и date_sunset()) | "35.2333" | PHP 5.0 |
| date.sunrise_zenith | Задаёт зенитный угол восхода по умолчанию (используется в date_sunrise() и date_sunset()) | "90.83" | PHP 5.0 |
| date.sunset_zenith | Задаёт зенитный угол заката по умолчанию (используется в date_sunrise() и date_sunset()) | "90.83" | PHP 5.0 |
PHP 5 Функции даты/времени
| Функция | Описание |
|---|---|
| checkdate() | Проверяет корректность григорианской даты. |
| date_add() | Добавляет дни, месяцы, годы, часы, минуты и секунды к дате. |
| date_create_from_format() | Возвращает новый объект DateTime, отформатированный в соответствии с указанным форматом. |
| date_create() | Возвращает новый объект DateTime. |
| date_date_set() | Устанавливает новую дату. |
| date_default_timezone_get() | Возвращает часовой пояс по умолчанию, используемый всеми функциями даты/времени. |
| date_default_timezone_set() | Устанавливает часовой пояс по умолчанию, используемый всеми функциями даты/времени. |
| date_diff() | Возвращает разницу между двумя датами. |
| date_format() | Возвращает дату, отформатированную в соответствии с указанным форматом. |
| date_get_last_errors() | Возвращает предупреждения/ошибки в строке даты. |
| date_interval_create_from_date_string() | Создаёт DateInterval из относительных частей строки. |
| date_interval_format() | Форматирует временной интервал. |
| date_isodate_set() | Устанавливает дату в формате ISO. |
| date_modify() | Изменяет временную метку. |
| date_offset_get() | Возвращает смещение часового пояса. |
| date_parse_from_format() | Возвращает ассоциативный массив с подробной информацией о заданной дате в соответствии с указанным форматом. |
| date_parse() | Возвращает ассоциативный массив с подробной информацией об указанной дате. |
| date_sub() | Вычитает дни, месяцы, годы, часы, минуты и секунды из указанной даты. |
| date_sun_info() | Возвращает массив, содержащий информацию о восходе/закате и начале/конце сумерек для указанной даты и местоположения. |
| date_sunrise() | Возвращает время восхода для указанной даты и местоположения. |
| date_sunset() | Возвращает время заката для указанной даты и местоположения. |
| date_time_set() | Устанавливает время. |
| date_timestamp_get() | Возвращает метку времени Unix. |
| date_timestamp_set() | Устанавливает дату и время на основе метки времени Unix. |
| date_timezone_get() | Возвращает часовой пояс заданного объекта DateTime. |
| date_timezone_set() | Устанавливает часовой пояс объекта DateTime. |
| date() | Форматирует локальную дату и время. |
| getdate() | Возвращает информацию о дате/времени для метки времени или текущей локальной даты/времени. |
| gettimeofday() | Возвращает текущее время. |
| gmdate() | Форматирует дату и время GMT/UTC. |
| gmmktime() | Возвращает метку времени Unix для даты GMT. |
| gmstrftime() | Форматирует дату и время GMT/UTC в соответствии с настройками локали. |
| idate() | Форматирует локальное время/дату как целое число. |
| localtime() | Возвращает локальное время. |
| microtime() | Возвращает микросекунды текущей временной метки Unix. |
| mktime() | Возвращает временную метку Unix для даты. |
| strftime() | Форматирует локальное время/дату в соответствии с настройками локали. |
| strptime() | Разбирает время/дату, сгенерированную strftime(). |
| strtotime() | Разбирает любое текстовое описание даты или времени на английском языке в временную метку Unix. |
| time() | Возвращает текущее время в виде временной метки Unix. |
| timezone_abbreviations_list() | Возвращает ассоциативный массив, содержащий летнее время, смещение и название часового пояса. |
| timezone_identifiers_list() | Возвращает числовой массив, содержащий все идентификаторы часовых поясов. |
| timezone_location_get() | Возвращает информацию о местоположении для указанного часового пояса. |
| timezone_name_from_ abbr() | Возвращает название часового пояса по его аббревиатуре. |
| timezone_name_get() | Возвращает имя часового пояса. |
| timezone_offset_get() | Возвращает смещение часового пояса относительно GMT. |
| timezone_open() | Создаёт новый объект DateTimeZone. |
| timezone_transitions_get() | Возвращает все переходы для часового пояса. |
| timezone_version_get() | Возвращает версию базы данных часовых поясов. |
Предопределённые константы даты/времени PHP 5
| Константа | Описание |
|---|---|
| DATE_ATOM | Atom (например, 2005-08-15T16:13:03+0000) |
| DATE_COOKIE | HTTP-куки (например, Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_ISO8601 | ISO-8601 (например, 2005-08-14T16:13:03+0000) |
| DATE_RFC822 | RFC 822 (например, Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_RFC850 | RFC 850 (например, Sunday, 14-Aug-05 16:13:03 UTC) |
| DATE_RFC1036 | RFC 1036 (например, Sunday, 14-Aug-05 16:13:03 UTC) |
| DATE_RFC1123 | RFC 1123 (например, Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_RFC2822 | RFC 2822 (например, Sun, 14 Aug 2005 16:13:03 +0000) |
| DATE_RSS | RSS (например, Sun, 14 Aug 2005 16:13:03 UTC) |
| DATE_W3C | W3C (e.g., 2005-08-14T16:13:03+0000) |