Fonctions PHP gmdate()Functions

PHP Date/TimeManuel de référence PHP Date/Time

Exemples

Formate une date et une heure GMT/UTC, et retourne la chaîne de date formatée :

<?php
// Affiche le jour
echo gmdate("l") . "<br>";

// Affiche le jour, la date, le mois, l'année, l'heure, AM ou PM
echo gmdate("l jS of F Y h:i:s A");
?>

Exécuter l'exemple »

Définition et utilisation

La fonction gmdate() formate une date et une heure GMT/UTC, et retourne la chaîne de date formatée.

Syntaxe

gmdate(format,timestamp);

Paramètre Description
format Obligatoire. Spécifie le format de la chaîne de date de sortie. Les caractères suivants peuvent être utilisés :
  • d - Jour du mois (de 01 à 31)
  • D - Une représentation textuelle du jour de la semaine (trois lettres)
  • j - Jour du mois sans zéro initial (1 à 31)
  • l (L minuscule) - Une représentation textuelle complète du jour de la semaine
  • N - La représentation numérique ISO-8601 du jour de la semaine (1 pour lundi, 7 pour dimanche)
  • S - Le suffixe ordinal anglais pour le jour du mois (2 caractères : st, nd, rd ou th. Fonctionne bien avec j)
  • w - Représentation numérique du jour de la semaine (0 pour dimanche, 6 pour samedi)
  • z - Le jour de l'année (de 0 à 365)
  • W - Le numéro de semaine ISO-8601 de l'année (les semaines commencent le lundi)
  • F - Une représentation textuelle complète du mois (janvier à décembre)
  • m - Représentation numérique du mois (de 01 à 12)
  • M - Une représentation textuelle abrégée du mois (trois lettres)
  • n - Représentation numérique du mois sans zéro initial (1 à 12)
  • t - Le nombre de jours dans le mois donné
  • L - Indique s'il s'agit d'une année bissextile (1 si c'est une année bissextile, 0 sinon)
  • o - Le numéro d'année ISO-8601
  • Y - Une représentation de l'année sur quatre chiffres
  • y - Une représentation de l'année sur deux chiffres
  • a - Forme en minuscules : am ou pm
  • A - Forme en majuscules : AM ou PM
  • B - Heure Internet Swatch (000 à 999)
  • g - format 12 heures sans zéro initial (1 à 12)
  • G - format 24 heures sans zéro initial (0 à 23)
  • h - format 12 heures avec zéros initiaux (01 à 12)
  • H - format 24 heures avec zéros initiaux (00 à 23)
  • i - Minutes avec zéros initiaux (00 à 59)
  • s - Secondes avec zéros initiaux (00 à 59)
  • u - Microsecondes (ajouté dans PHP 5.2.2)
  • e - Identifiant de fuseau horaire (par ex. : UTC, GMT, Atlantic/Azores)
  • I (i majuscule) - Indique si la date est à l'heure d'été (1 si heure d'été, 0 sinon)
  • O - Différence par rapport au temps moyen de Greenwich (GMT) en heures (exemple : +0100)
  • P - Décalage par rapport à l'heure de Greenwich (GMT) en heures:minutes (ajouté dans PHP 5.1.3)
  • T - Abréviation de fuseau horaire (exemples : EST, MDT)
  • Z - Décalage de fuseau horaire en secondes. Le décalage pour les fuseaux horaires à l'ouest d'UTC est négatif (-43200 à 50400)
  • c - La date ISO-8601 (par ex. 2013-05-05T16:34:42+00:00)
  • r - La date formatée selon la RFC 2822 (par ex. Fri, 12 Apr 2013 12:01:05 +0200)
  • U - Le nombre de secondes écoulées depuis l'époque Unix (1er janvier 1970 00:00:00 GMT)

De plus, les constantes prédéfinies suivantes peuvent être utilisées (disponibles depuis PHP 5.1.0) :

  • DATE_ATOM - Atom (ex. : 2013-04-12T15:52:01+00:00)
  • DATE_COOKIE - Cookies HTTP (ex. : Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_ISO8601 - ISO-8601 (ex. : 2013-04-12T15:52:01+0000)
  • DATE_RFC822 - RFC 822 (ex. : Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC850 - RFC 850 (ex. : Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_RFC1036 - RFC 1036 (ex. : Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC1123 - RFC 1123 (ex. : Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC2822 - RFC 2822(Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC3339 - Identique à DATE_ATOM (depuis PHP 5.1.3)
  • DATE_RSS - RSS(Fri, 12 Aug 2013 15:52:01 +0000)
  • DATE_W3C - World Wide Web Consortium (ex. : 2013-04-12T15:52:01+00:00)
timestamp Facultatif. Spécifie un horodatage Unix entier. La valeur par défaut est l'heure locale actuelle (time()).

Détails techniques

Valeur de retour : Retourne la chaîne de date formatée en cas de succès, ou émet un E_WARNING et retourne FALSE en cas d'échec.
Version de PHP : 4+
Journal des modifications : PHP 5.1.0 : La plage valide d'horodatages va du vendredi 13 décembre 1901 20:45:54 GMT au mardi 19 janvier 2038 03:14:07 GMT. Avant la version 5.1.0, sur certains systèmes (par ex. Windows), les horodatages étaient limités à 01-01-1970 à 19-01-2038.
PHP 5.1.1 : Ajout de constantes standard de format date/heure pour spécifier le paramètre format.


PHP Date/TimeManuel de référence PHP Date/Time Autres extensions