PHP date()Функции

PHP Date/TimeСправочное руководство по дате/времени PHP

Примеры

Форматирует локальную дату и время и возвращает отформатированную строку даты:

<?php //Установить часовой пояс date_default_timezone_set("PRC"); //Вывести текущее время. PHP_EOL — символ новой строки, совместим с разными системами echo date("Y-m-d H:i:s") . PHP_EOL; echo date("Y год, m месяц, d день, H час, i минута, s секунда") . PHP_EOL; //Указать время $time = strtotime("2018-01-18 08:08:08"); //Преобразовать указанную дату в метку времени echo date("Y-m-d H:i:s", $time) . PHP_EOL; ?>

Вывод следующий:

2018-01-31 22:09:35
2018 年 01 月 31 日 22 点 09 分 35 秒
2018-01-18 08:08:08

Определение и использование

Функция date() форматирует локальную дату и время и возвращает отформатированную строку даты.

Синтаксис

date(format,timestamp);

Возвращает строку, сформированную в соответствии с заданной строкой формата, используя целочисленную метку времени. Если метка времени не указана, используется текущее локальное время. Иными словами, timestamp необязателен и по умолчанию равен time().


Параметр Описание
format Обязательный. Задает формат выходной строки даты. Можно использовать следующие символы:
  • d - День месяца (от 01 до 31)
  • D - Текстовое представление дня недели (три буквы)
  • j - День месяца без ведущих нулей (от 1 до 31)
  • l (строчная 'L') - Полное текстовое представление дня недели
  • N - Числовое представление дня недели по ISO-8601 (1 для понедельника, 7 для воскресенья)
  • S - Английский порядковый суффикс для дня месяца (2 символа: st, nd, rd или th. Используется с j)
  • w - Числовое представление дня недели (0 для воскресенья, 6 для субботы)
  • z - День года (от 0 до 365)
  • W - Номер недели года по ISO-8601 (недели начинаются с понедельника)
  • F - Полное текстовое представление месяца (с января по декабрь)
  • m - Числовое представление месяца (от 01 до 12)
  • M - Краткое текстовое представление месяца (три буквы)
  • n — числовое представление месяца без ведущих нулей (от 1 до 12)
  • t — количество дней в данном месяце
  • L — является ли год високосным (1, если високосный, иначе 0)
  • o — номер года по ISO-8601
  • Y — четырёхзначное представление года
  • y — двузначное представление года
  • a — строчные обозначения до полудня и после полудня: am или pm
  • A — прописные обозначения до полудня и после полудня: AM или PM
  • B — Swatch Internet Time (от 000 до 999)
  • g — 12-часовой формат без ведущих нулей (от 1 до 12)
  • G — 24-часовой формат без ведущих нулей (от 0 до 23)
  • h — 12-часовой формат с ведущими нулями (от 01 до 12)
  • H - 24-часовой формат с ведущими нулями (от 00 до 23)
  • i - Минуты с ведущими нулями (от 00 до 59)
  • s - Секунды с ведущими нулями (от 00 до 59)
  • u - Микросекунды (новое в PHP 5.2.2)
  • e - Идентификатор часового пояса (например: UTC, GMT, Atlantic/Azores)
  • I (заглавная i) - Указывает, действует ли летнее время для даты (1, если действует летнее время, иначе 0)
  • O - Смещение относительно среднего времени по Гринвичу (GMT) в часах (пример: +0100)
  • P - Смещение относительно среднего времени по Гринвичу (GMT) в часах:минутах (новое в PHP 5.1.3)
  • T - Аббревиатура часового пояса (примеры: EST, MDT)
  • Z - Смещение часового пояса в секундах. Смещение для часовых поясов западнее UTC отрицательное (от -43200 до 50400)
  • c - Дата в формате ISO-8601 (например, 2013-05-05T16:34:42+00:00)
  • r - Дата в формате RFC 2822 (например, Fri, 12 Apr 2013 12:01:05 +0200)
  • U - Секунды с начала эпохи Unix (1 января 1970 00:00:00 GMT)

Следующие предопределённые константы также можно использовать (доступны с PHP 5.1.0):

  • DATE_ATOM - Atom (например, 2013-04-12T15:52:01+00:00)
  • DATE_COOKIE - HTTP-куки (например, Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_ISO8601 - ISO-8601 (например, 2013-04-12T15:52:01+0000)
  • DATE_RFC822 - RFC 822 (например, Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC850 - RFC 850 (например, Friday, 12-Apr-13 15:52:01 UTC)
  • DATE_RFC1036 - RFC 1036 (например, Fri, 12 Apr 13 15:52:01 +0000)
  • DATE_RFC1123 - RFC 1123 (например, Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC2822 - RFC 2822(Fri, 12 Apr 2013 15:52:01 +0000)
  • DATE_RFC3339 - То же, что DATE_ATOM (начиная с PHP 5.1.3)
  • DATE_RSS - RSS(Fri, 12 Aug 2013 15:52:01 +0000)
  • DATE_W3C — Консорциум Всемирной паутины (например, 2013-04-12T15:52:01+00:00)
timestamp Необязательно. Задает целочисленную метку времени Unix. По умолчанию используется текущее местное время (time()).

Технические детали

Возвращаемое значение: Возвращает отформатированную строку даты в случае успеха или выдает ошибку E_WARNING и возвращает FALSE при неудаче.
Версия PHP: 4+
Список изменений: PHP 5.1.0: Добавлены ошибки часового пояса E_STRICT и E_NOTICE. Допустимый диапазон меток времени — с пятницы, 13 декабря 1901 г., 20:45:54 GMT по вторник, 19 января 2038 г., 03:14:07 GMT. До версии 5.1.0 в некоторых системах (например, Windows) метки времени были ограничены диапазоном с 01-01-1970 по 19-01-2038.
PHP 5.1.1: Добавлены стандартные константы формата даты/времени для параметра format.


PHP Date/TimeСправочное руководство по дате/времени PHP Другие расширения