PHP date()Fonctions
Manuel de référence PHP Date/Time
Exemples
Formate une date et une heure locales, et retourne la chaîne de date formatée :
<?php
date_default_timezone_set("PRC");
echo date("Y-m-d H:i:s") . PHP_EOL;
echo date("Y année m mois d jour H heure i minute s seconde") . PHP_EOL;
$time = strtotime("2018-01-18 08:08:08");
echo date("Y-m-d H:i:s", $time) . PHP_EOL;
?>
La sortie est la suivante :
2018-01-31 22:09:35
2018 年 01 月 31 日 22 点 09 分 35 秒
2018-01-18 08:08:08
Définition et utilisation
La fonction date() formate une date et une heure locales, et retourne la chaîne de date formatée.
Syntaxe
Retourne une chaîne produite selon la chaîne de format donnée en utilisant le timestamp entier. Si aucun timestamp n'est donné, l'heure locale actuelle est utilisée. En d'autres termes, timestamp est facultatif et vaut par défaut time().
| Paramètre |
Description |
| format |
Obligatoire. Spécifie le format de la chaîne de date de sortie. Les caractères suivants peuvent être utilisés :
- d - Jour du mois (de 01 à 31)
- D - Une représentation textuelle du jour de la semaine (trois lettres)
- j - Jour du mois sans zéro initial (1 à 31)
- l (L minuscule) - Une représentation textuelle complète du jour de la semaine
- N - Représentation numérique ISO-8601 du jour de la semaine (1 pour lundi, 7 pour dimanche)
- S - Suffixe ordinal anglais pour le jour du mois (2 caractères : st, nd, rd ou th. Utilisé avec j)
- w - Représentation numérique du jour de la semaine (0 pour dimanche, 6 pour samedi)
- z - Le jour de l'année (de 0 à 365)
- W - Numéro de semaine ISO-8601 de l'année (les semaines commencent le lundi)
- F - Une représentation textuelle complète d'un mois (de janvier à décembre)
- m - Représentation numérique d'un mois (de 01 à 12)
- M - Une représentation textuelle abrégée d'un mois (trois lettres)
- n - Représentation numérique d'un mois, sans zéros initiaux (1 à 12)
- t - Nombre de jours dans le mois donné
- L - Indique s'il s'agit d'une année bissextile (1 si c'est une année bissextile, 0 sinon)
- o - Numéro d'année ISO-8601
- Y - Représentation d'une année sur quatre chiffres
- y - Représentation d'une année sur deux chiffres
- a - Ante meridiem et Post meridiem en minuscules : am ou pm
- A - Ante meridiem et Post meridiem en majuscules : AM ou PM
- B - Heure Internet Swatch (000 à 999)
- g - Format 12 heures, sans zéros initiaux (1 à 12)
- G - Format 24 heures, sans zéros initiaux (0 à 23)
- h - Format 12 heures, avec zéros initiaux (01 à 12)
- H - Format 24 heures, avec zéros initiaux (00 à 23)
- i - Minutes, avec zéros initiaux (00 à 59)
- s - Secondes, avec zéros initiaux (00 à 59)
- u - Microsecondes (nouveau dans PHP 5.2.2)
- e - Identifiant de fuseau horaire (par ex. : UTC, GMT, Atlantic/Azores)
- I (i majuscule) - Indique si la date est à l'heure d'été (1 si heure d'été, 0 sinon)
- O - Différence par rapport au temps moyen de Greenwich (GMT) en heures (exemple : +0100)
- P - Différence par rapport au temps moyen de Greenwich (GMT) en heures:minutes (nouveau dans PHP 5.1.3)
- T - Abréviation de fuseau horaire (exemples : EST, MDT)
- Z - Décalage de fuseau horaire en secondes. Le décalage pour les fuseaux horaires à l'ouest d'UTC est négatif (-43200 à 50400)
- c - Date ISO-8601 (par ex., 2013-05-05T16:34:42+00:00)
- r - Date au format RFC 2822 (par ex., Fri, 12 Apr 2013 12:01:05 +0200)
- U - Secondes depuis l'époque Unix (1er janvier 1970 00:00:00 GMT)
Les constantes prédéfinies suivantes peuvent également être utilisées (disponibles depuis PHP 5.1.0) :
- DATE_ATOM - Atom (par exemple, 2013-04-12T15:52:01+00:00)
- DATE_COOKIE - Cookies HTTP (par exemple, Friday, 12-Apr-13 15:52:01 UTC)
- DATE_ISO8601 - ISO-8601 (par exemple, 2013-04-12T15:52:01+0000)
- DATE_RFC822 - RFC 822 (par exemple, Fri, 12 Apr 13 15:52:01 +0000)
- DATE_RFC850 - RFC 850 (par exemple, Friday, 12-Apr-13 15:52:01 UTC)
- DATE_RFC1036 - RFC 1036 (par exemple, Fri, 12 Apr 13 15:52:01 +0000)
- DATE_RFC1123 - RFC 1123 (par exemple, Fri, 12 Apr 2013 15:52:01 +0000)
- DATE_RFC2822 - RFC 2822(Fri, 12 Apr 2013 15:52:01 +0000)
- DATE_RFC3339 - Identique à DATE_ATOM (depuis PHP 5.1.3)
- DATE_RSS - RSS(Fri, 12 Aug 2013 15:52:01 +0000)
- DATE_W3C - World Wide Web Consortium (par exemple, 2013-04-12T15:52:01+00:00)
|
| timestamp |
Facultatif. Spécifie un horodatage Unix entier. La valeur par défaut est l'heure locale actuelle (time()). |
Détails techniques
| Valeur de retour : |
Retourne la chaîne de date formatée en cas de succès, ou émet une erreur E_WARNING et retourne FALSE en cas d'échec. |
| Version PHP : |
4+ |
| Journal des modifications : |
PHP 5.1.0 : Ajout des erreurs de fuseau horaire E_STRICT et E_NOTICE. La plage valide des horodatages s'étend du vendredi 13 décembre 1901 20:45:54 GMT au mardi 19 janvier 2038 03:14:07 GMT. Avant 5.1.0, sur certains systèmes (par exemple, Windows), les horodatages étaient limités du 01-01-1970 au 19-01-2038. PHP 5.1.1 : Ajout des constantes de format de date/heure standard pour le paramètre format. |
Manuel de référence Date/Heure PHP Autres extensions